yasuoza diary

web and life

Solved unable to install nokogiri to ubuntu 12.04

I tried install nokogiri into my ubuntu 12.04 server, but failed with following error message

1
2
3
4
5
6
7
8
9
checking for libxml/parser.h... yes
checking for libxslt/xslt.h... yes
checking for libexslt/exslt.h... yes
checking for iconv_open() in iconv.h... yes
checking for xmlParseDoc() in -lxml2... yes
checking for xsltParseStylesheetDoc() in -lxslt... no
-----
libxslt is missing.  please visit http://nokogiri.org/tutorials/installing_nokogiri.html for help with installing dependencies.
-----

Official install guide page and many other sites said to install libxslt1-dev, but it does not solve my problem.

Ubuntu 12.04 installs libxslt1-dev instead of libxslt-dev, so I installed libxslt source code(libxslt-1.1.22) and installed by myself.

Then I cloud install nokogiri.

Comments